Jump to content
Eric Aitala

New IPMS/USA Website

Recommended Posts

Hi Folks,

 

Tonight I uploaded the new IPMS/USA website. It is probably the biggest change to the site in the last ten years or so...

 

But before I get too far, if you encounter a problem with the website, including problems with the archive of the previous site, please post in this topic >> http://forum.ipmsusa3.org/index.php?/topic/14261-ipmsusa-website-issues/. I would like to keep issues separate from this topic.

 

So what has changed?

  1. No more frames! So now you can actually link to a real page without losing the navigation. This will really help with Google searches as well.
  2. Desktop and Mobile (phones and tablets) responsive theme. This means that a single HTML file can do both a desktop and mobile version of a page. A good percentage of the visits to the site are via mobile devices and that number has risen steadily for the past few years.
  3. Simpler navigation. Most of the site can be reached via the main menu bar and the dropdown menus. There are a few pages which have side menus to dig deeper, but not too many.
  4. Modern code - the site was built with the latest version of HTML which means it should be good for many years. This does mean that older, out of date browsers may have some issues, but they also have many security issues, so you should probably update. If you are using a browser that is not current, you will be a small, closable notice at the top of the page which provides a link to download an alternative browser.
  5. A lot cleaner - both in appearance and the number and location of files.

So what is left to do?

  1. There are still some files still to be updated - mostly the Executive Board Meeting Minutes - but the previous site is archived at: http://www.ipmsusa.org/archive/index.htm so if there is a page you cannot find, it'll still be available.
  2. There are a few graphical and functional additions I would like to do, but those can probably wait.
  3. One page I need to clean up a bit is: http://www.ipmsusa.org/national_contest_committee/modelers_guide_2013.htm
  4. I'd like to add a search functionality - will probably need to wait until Google indexes the new site for that...

 

Here is where I am keeping track of the things to finish up and the suggestions made so far >> https://trello.com/b/YM8X891Z

 

If you have any questions, comments, or suggestions, please reply to this topic and I will reply ASAP.

 

Thanks much,

Eric

Edited by Eric Aitala
I'm adding a link to my task board with some of the suggestions made so far.
  • Like 1

Share this post


Link to post
Share on other sites

Really not liking the new look, and especially not happy with eventually finding the forum button at the bottom, it it takes me to most recent posts. I don't want to go to recent posts.

Share this post


Link to post
Share on other sites

Thanks for your work on all this and keeping us up and running!

Share this post


Link to post
Share on other sites

Eric

 

I always liked having our American Flag in the top zone, and more obvious, on our web page.

  • Like 1

Share this post


Link to post
Share on other sites

It is linked in the menu bar, but I can either alter the text in the lower button or the link.

 

forums.png

 

Eric

 

Really not liking the new look, and especially not happy with eventually finding the forum button at the bottom, it it takes me to most recent posts. I don't want to go to recent posts.

 

Share this post


Link to post
Share on other sites

"I always liked having our American Flag in the top zone, and more obvious, on our web page."

 

FWIW, I agree with Ralph. I really liked the colorful American flag header.

  • Like 1

Share this post


Link to post
Share on other sites

It works the way that I expect it to work. Good job.

Share this post


Link to post
Share on other sites

Looking good, Eric! Thanks for all your work.

Share this post


Link to post
Share on other sites

I like the improved navigation and cleaner look. Personally I think the sections on the home page look a little too similar and tend to run together - I'd like some borders or shading just to visually separate the sections, but I know this super-sparse style is in fashion on the internet. Oh yeah - I like red buttons too - the blue buttons tend to blend in with the menu-bar and text, but again a matter of taste.

 

Major comment: The home page doesn't have any pictures of models! Nothing to suggest what the hobby or the organization is all about. This is the main public facing page for the organization; it should "sell" a little bit (we can have an internal page for members to bookmark to get them to the top level sections). For examples check out http://www.nmra.org/, http://www.tripoli.org/ or http://www.nar.org/ (model railroad and model rocketry organizations).

 

Thanks for all the hard work!

 

Don

Edited by Schmitz

Share this post


Link to post
Share on other sites

A quick note - I am keeping an eye on suggestions for changes to the site. They are much appreciated. I've got a couple other tasks to finish and there is an issue with the web server needs to get resolved first.

 

Thanks again..

 

Eric

Share this post


Link to post
Share on other sites

Eric:

 

I noticed when I hit the button at the Bottom of the review, it say "Page not Found" but I am on the base screen for the reviews

 

Dave

Share this post


Link to post
Share on other sites

Hm.. That's an odd one - no idea how that got changed. I fixed the link.

 

Eric

 

Eric:

 

I noticed when I hit the button at the Bottom of the review, it say "Page not Found" but I am on the base screen for the reviews

 

Dave

Share this post


Link to post
Share on other sites

Yup- Works good now.

 

FWIW, it would eb cool to have some models on the front page. Maybe like the last bunch of Nationals winners or something

Dave

Share this post


Link to post
Share on other sites

Don has some great points. I really like it overall. Much nicer. Great job!

 

 

I like the improved navigation and cleaner look. Personally I think the sections on the home page look a little too similar and tend to run together - I'd like some borders or shading just to visually separate the sections, but I know this super-sparse style is in fashion on the internet. Oh yeah - I like red buttons too - the blue buttons tend to blend in with the menu-bar and text, but again a matter of taste.

 

Major comment: The home page doesn't have any pictures of models! Nothing to suggest what the hobby or the organization is all about. This is the main public facing page for the organization; it should "sell" a little bit (we can have an internal page for members to bookmark to get them to the top level sections). For examples check out http://www.nmra.org/, http://www.tripoli.org/ or http://www.nar.org/ (model railroad and model rocketry organizations).

 

Thanks for all the hard work!

 

Don

Share this post


Link to post
Share on other sites

Another suggestion on models on front page is to cycle through review kits, once you run out of Nationals winners - put them on a rotating display, keep maybe 10-12 on the cycle for a week then freshen with another dozen ...

Share this post


Link to post
Share on other sites

Eric,

 

Good idea making your activities transparent. We all get to see how you are proceeding in implementing our suggestions toward making our web page even better. Your responsiveness is very much appreciated.

 

Excellent job with the web page these recent years and glad you are sticking with it- THANK YOU.

Share this post


Link to post
Share on other sites

Can't bring up IPMS home page anymore, get a 404 error message. Tried to goggle IPMS and hit the link for IPMS USA and same thing happened. Also my book mark link does not work anymore. I was able to getthis meesage out by going to the IPMS forum page link. What's up! And for the record I can't get the new IPMS page to come up. Is the old link still active or down? Is the old home page link going to go away and only the new page. Very confused. Issue has only happen over the past day or so.

 

Thanks,

 

Chris G

Share this post


Link to post
Share on other sites

What are you linking to? www.ipmsusa.org should work...

E

 

 

Can't bring up IPMS home page anymore, get a 404 error message. Tried to goggle IPMS and hit the link for IPMS USA and same thing happened. Also my book mark link does not work anymore. I was able to getthis meesage out by going to the IPMS forum page link. What's up! And for the record I can't get the new IPMS page to come up. Is the old link still active or down? Is the old home page link going to go away and only the new page. Very confused. Issue has only happen over the past day or so.

Thanks,

Chris G

Share this post


Link to post
Share on other sites

www.ipmsusa.org is what i have been triying to connect to. When i do a search and the link comes up and i click on it I get the error code. I have tried this at home and work aand both times i get the same thing.

 

Chris g.

Share this post


Link to post
Share on other sites

Hi,

 

Try http://www.ipmsusa.org/index.shtml - if that does not work, I'll be really surprised.

 

Am working on getting the dead link fixed on Google, plus getting the 404 page on the server fixed... been trying to get tech support to fix the latter for three days.

 

E

 

 

www.ipmsusa.org is what i have been triying to connect to. When i do a search and the link comes up and i click on it I get the error code. I have tried this at home and work aand both times i get the same thing.

 

Chris g.

Edited by Eric Aitala
Messed up link

Share this post


Link to post
Share on other sites

Had the error a couple times this AM but it cleared up

 

Dave

Share this post


Link to post
Share on other sites

Hi,

 

Try http://www.ipmsusa.org/index.shtml - if that does not work, I'll be really surprised.

 

Am working on getting the dead link fixed on Google, plus getting the 404 page on the server fixed... been trying to get tech support to fix the latter for three days.

 

E

 

 

www.ipmsusa.org is what i have been triying to connect to. When i do a search and the link comes up and i click on it I get the error code. I have tried this at home and work aand both times i get the same thing.

 

Chris g.

 

Nope nothing. will not let me connect.

Edited by Eric Aitala
Fixed broken IPMS link, just in case anyone tries to use it

Share this post


Link to post
Share on other sites

×